BUG: Links don't work in IE5

First of all, great script! 2nd of all, a bug... ( If you view a easyphpalbum with Internet Explorer 5, you won't be able to click on any of the links. (So you won't be able to view images or go to another page.) To test this you can download a standalone version of IE5 from [url]http//downloads.skyzyx.com/index.php?fpp=20&did=8[/url] (I used 5.01 SP2.) I've already tried to figure out how to solve it, but no luck there yet. (I thought it had something to do with the way the links are displayed, so the 'a href' or the javascript part... But I'll leave it to the professional(s)... ;) ) Thanks in advance for looking into this!

Re:BUG: Links don't work in IE5

admin wrote
Do you have some more details as to which line in the page source code is causing the error and which links do not work? (and post the page source code)
Working on that now. Javascript is my weak point, but when I find out, I will post my findings.

You can believe it or not, but I don't have a computer of my own...I have one from work and I am really carefull not to mess it up by loading IE5.0 (even though you tell me it's 100% safe...)
Hard to imagine, but I do believe, and from a work IT point of view, I thank your for not wanting to mess up your workstation(s), and I know your IT staff appreciates it too!

You could also try the following

replace all occurences of '#link' with 'javascript//'
OK, that sounds like a good weekend project when I have time to find/replace and test.

BTW IE5.x has serious security issues so people that are still running with this version should really upgrade to the latest version anyway ;)
I could not agree more, and have told members of my main website this, but many are elderly, on dialup, opposed/afraid of change etc., or a combination of all of the above. As cumbersome a process as it is to upgrade to IE6 for most lay persons, it is just a lost cause. Unfortunately as "webmasters" we have to cater to the masses at times (Post edited by 911radio, at 2005/12/15 0140

Re:BUG: Links don't work in IE5

Do you have some more details as to which line in the page source code is causing the error and which links do not work? (and post the page source code)

You can believe it or not, but I don't have a computer of my own...I have one from work and I am really carefull not to mess it up by loading IE5.0 (even though you tell me it's 100% safe...)

You could also try the following

replace all occurences of '#link' with 'javascript//'

BTW IE5.x has serious security issues so people that are still running with this version should really upgrade to the latest version anyway ;)Post edited by admin, at 2005/12/14 2014

Re:BUG: Links don't work in IE5

Well, I have begun to investigate this myself as I have been getting numerous complaints from IE5.x users.

I have downloaded the emulator and have come to the conclusion that something in the scripts javascript coding and how IE5.x handles it. Different versions of IE seem to handle certain javascript code and applets differently and many scripts are not compatible with older versions of IE. For non believers of that last statement, go to Dynamic Drive.com and you will see how many scripts are only compatible with IEx or NSx etc.

Perhaps there are some areas of the EasyPHPAlbum scripts javascript that can be tweaked to be more "old school" browser friendly. It certainly is a problem that may lead me to abandon the use of the script ( as the internet (for good or bad) is still loaded with people using older browsers (and OS versions).

Re:BUG: Links don't work in IE5

admin wrote
...
(I can only test with IE6 and Firefox, and I don't feel like gambling and messing up my system with IE5.. S )
Don't worry, it's not a gamble. The link I provided above is a small, standalone version, specifically meant for testing. You won't even have to install it.

The reason it's is such a problem for me, is that I've used easyphpalbum for a client, that uses Win2k in their company. And IE5 is the default browser on Win2k. Also, IE5.2 on Mac has the same problem. I'll let you know if I find an answer, but I'm afraid I don't have the time right now.

Re:BUG: Links don't work in IE5

Hi bazzz

Thanks for the feedback!

May I suggest that this is a bug in IE5 woohoo ?!

EasyPhpAlbum works with so many different browsers (IE, Firefox, Safari, etc.) that there must be something 'off' with IE5. Are you sure your security settings etc. are not too strict? EasyPhpAlbum makes use of javascript, perhaps you have disabled it....

But thanks for your comment, should you find the solution I would be interested in knowing about it!

(I can only test with IE6 and Firefox, and I don't feel like gambling and messing up my system with IE5.. S )